Posted on

Yahoo! Recent Investigation

Yahoo! provides more information about their recent (2014) attack that has compromised¬†usernames and passwords. It’s highly recommended if you use Yahoo! Mail, to update as soon as possible. More about the security breach:

We have confirmed, based on a recent investigation, that a copy of certain user account information was stolen from our network in late 2014 by what we believe is a state-sponsored actor.

Source: Account Security Issue FAQs | Account Help – SLN27925